Switchvox users unable to configure Talk app or Login to Meet
Incident Report for Sangoma
Resolved
This incident has been resolved as of 11pm EDT.
Posted May 01, 2024 - 23:17 EDT
Investigating
We've identified an issue impacting the performance of Sangoma Talk and Meet services for Switchvox customers, resulting in degraded performance. We are aware of this problem and actively working to resolve it.
Posted May 01, 2024 - 15:33 EDT
This incident affected: Collaboration as a Service (Sangoma Meet, Sangoma Talk).